• Register
Welcome to Minecraft Help - Questions & Answers

Here you can ask Minecraft related questions or help other players by answering their questions.
Community driven website maintained by Minecraft Servers - A list with thousands of playable servers for Minecraft.

We recommend Mojangs new official bug tracker, letting them know about errors, will help speed up development to close bugs. Visit at Minecraft Bug Tracker
  • Minecraft Skins
  • Minecraft Stats
  • How can I disable command blocks in single player

    +4 votes
    I accedentaly put a command block somewhere with a redstone clock, and now i can't turn it off because i lost the coordinates, i dont want to loose my world :( Please help
    asked Apr 11, 2013 in Redstone Circuits by Ayham Al Akhras (160 points)

    15 Answers

    +1 vote
    I don't think it is possible to turn it off.

    If you aren't in range of the redstone clock it is unloaded and shouldn't tick anyway.

    Why is this a problem actually?
    answered May 8, 2013 by Nikecow (7,410 points)
    well the way I recall I did it (a couple years ago now lol) was i just placed tnt somehow and than set it on fire so it fell to the ground and blew up the command block. Now I can't recall whether you can even blow up a command block but to my knowledge that's what I did
    If you write /gamerule maxCommandChainLength 0 it should work. (1.14)
    THANK YOU, I'm making a horror map for my friend to play and ive put over 80 hours of detailing it etc and you just saved me
    I know this is an old thread but I'm having a similar problem now.  Frankly, what does it matter if it's a problem for the player or not?  He asked the question because it is a problem.  The reply "Why is this a problem?" is irrelevant.
    Um I need help I accidentally forgot that I was using a repeating command block, and teleported myself to the front of my house and now i cant move because my clock is hecka fast and on the lower level there is another repeating command block spamming gold blocks and I can’t turn it off. I’m surprised my game isn’t lagging, because it’s been going on for 20 minutes while the ui screen “text to chat” is going on over and over saying “you have been teleported to minus three hundred seventy five point five zero. ninety seven point zero zero. one thousand one hundred fifty one point five zero.” Help!!! Can I stop this?
    +1 vote
    It's horrible! I've also connected a quick clock to a tp commandblock!
    answered Sep 16, 2013 by anonymous
    me TOO D: ):
    now wah are we upost ah do
    +1 vote
    It's horrible! I've also connected a clock to a tp commandblock that makes me go down and it keeps on make me fall of the world ! HEEEEEEEEELLP !!!
    answered Sep 16, 2013 by anonymous
    +1 vote
    maybe put the world on a server  and put command blocks to false and then save the world and go back to

     single player
    answered Sep 27, 2013 by anonymous
    wow it worked thx =D
    0 votes
    The only answer is that you have to tp near the command block and you have to spam and while you do that you right click it.

    And I had a freaken castle and i was finished then i did tp instead of tp by accident on a command block.
    answered Mar 22, 2014 by anonymous
    0 votes
    I put a command block to summon particles i accidentally put it to an extremely laggy summoner now i cant destroy it because its soooo laggy. How do i break the block?
    answered Feb 2, 2015 by anonymous
    0 votes
    well i had a similar problem the fix is to copy /gamerule commandBlockOutput false then go to your options while you are in the main menu make the fps limit 10 and but 32 chunks and this is gonna give you enough time to open the chat and past the command then command blocks will not activate commands then search for the command block and fix it the turn on command blocks back on by using this command:/gamerule commandBlockOutput true but some times when you copy a command from a wepsite it get's corrupted so try it in note pad and if you see symbols just delete them and you should be good
    answered Nov 10, 2015 by anonymous
    No, this is to prevent CHAT SPAM, not disable command blocks
    0 votes
    I did the same thing I'm making a map I have the command "/kill @e[type=!Player]" to kill all entities but the player but then I was trying to stop items being killed so on the side of the torch I put "/kill @e[type=!Item]" it didn't work so I researched a way to stop item dropping but the kill all but player command still destroyed it so I broke the torch to see if the command worked it did, so I placed the torch back and it triggered the kill all but item command leading me to n /kill constantly I cant lose any of my work I don't mind losing my last session though please help soon as possible
    answered Jan 4, 2016 by Snootnoot2
    /kill @e[type=!Player,type=!item]
    0 votes
    I put a command block with a tp command and it wont stop teleporting me far away from the command block. about 200 blocks away.so my first thought was buy realms or realms trial and put the world on there. turn off commandblocks fix the problem then save it to saves again.but I don't have 7.99 to spend every month! please help! I'm trying to find a command that shuts off commandblocks. anything might help. ps: I'm to far away to see it. so I cant use reach.
    answered Nov 27, 2016 by anonymous
    try turning off command blocks enabled in your game settings so you can go and destroy the block.
    0 votes
    There is an application called MCEdit. This can edit the world without actually being on the world, making you able to do basically anything. What you want to do is download it, then you need to navigate to the command block. After finding it, select the button on the left side panel, which should be labelled "Flood Fill". After selecting that, choose the block you want to change it to, which most people would choose air. Then, click your command block and make sure that you have stayed on the flood fill tool, which will then fill the command block with air! You can't disable the command block, but you can get rid of it which will disable the one command. Next time you log back onto your world, you will not be killed repeatedly, or whatever repeating command block you have!
    answered Aug 16, 2018 by IjustWonLIFE24
    mine doesn't work it just keeps glitching and I'm trying to fix the repeator of command block set to /kill @p and I'm trying to fix this on 1.13.2